
<!DOCTYPE html>
<!--[if lt IE 7]> <html class="no-js lt-ie9 lt-ie8 lt-ie7 modePublish"> <![endif]-->
<!--[if IE 7]> <html class="no-js lt-ie9 lt-ie8 modePublish"> <![endif]-->
<!--[if IE 8]> <html class="no-js lt-ie9 modePublish"> <![endif]-->
<!--[if gt IE 8]><!--><html class="no-js modePublish"><!--<![endif]-->






  <head>
    
    
    <!-- Begin comScore Tag -->
    <script>
      document.write(unescape("%3Cscript src='" + (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js' %3E%3C/script%3E"));
    </script>
    <script>
    if (typeof COMSCORE !== 'undefined') {
      COMSCORE.beacon({
        c1:"2", c2: "18406752", c4: "http://www.slate.com/blogs/browbeat/2017/07/18/seth_meyers_has_more_trump_scandals_than_he_knows_what_to_do_with.html"
      });
    } else {
      (function (w, d) {
        d.addEventListener('DOMContentLoaded', function(event) {
          var img = d.createElement('img');
          img.src = 'http://b.scorecardresearch.com/p?c1=2&c2=18406752&c3=&c4=http://www.slate.com/blogs/browbeat/2017/07/18/seth_meyers_has_more_trump_scandals_than_he_knows_what_to_do_with.html&c5=&c6=&c15=&cj=1';
          d.body.appendChild(img);
        });
      } (window, document));
    }
    </script>
    <noscript>
      <img src="http://b.scorecardresearch.com/p?c1=2&c2=18406752&c3=&c4=http://www.slate.com/blogs/browbeat/2017/07/18/seth_meyers_has_more_trump_scandals_than_he_knows_what_to_do_with.html&c5=&c6=&c15=&cj=1" />
    </noscript>
    <!-- End comScore Tag -->
    
    


    
    
    <!--  Quantcast Tag -->
        <script>
         var ezt = ezt ||[];

         (function(){
           var elem = document.createElement('script');
           elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://pixel") + ".quantserve.com/aquant.js?a=p-fw53_-Tq3MNK1";
           elem.async = true;
           elem.type = "text/javascript";
           var scpt = document.getElementsByTagName('script')[0];
           scpt.parentNode.insertBefore(elem,scpt);
         }());


         ezt.push({qacct: 'p-fw53_-Tq3MNK1',
               uid: ''
                   });
        </script>
        <noscript>
          <img src="//pixel.quantserve.com/pixel/p-fw53_-Tq3MNK1.gif" style="display: none;" border="0" height="1" width="1" alt="Quantcast"/>
        </noscript>
    <!-- End Quantcast Tag -->
    
    

    <script>
      //Reload to canonical if you try to paste in the print page
      if (window.location.search.indexOf("print") > -1) {
        if (document.referrer.indexOf("http://www.slate.com/blogs/browbeat/2017/07/18/seth_meyers_has_more_trump_scandals_than_he_knows_what_to_do_with.html") != 0) {
          window.location = "http://www.slate.com/blogs/browbeat/2017/07/18/seth_meyers_has_more_trump_scandals_than_he_knows_what_to_do_with.html";
        }
      }
      //-- Stop hiding script -->
    </script>
    <script type="text/javascript">
      var slate_public_url = "http://www.slate.com/";
    </script>
    <meta charset="utf-8">
    <meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
    <title>Seth Meyers has more Trump scandals than he knows what to do with.</title>

     

    <meta name="description" content="You know that scene at the end of the movie about the aging racehorse and the juvenile delinquent, where it seems like they&rsquo;ve lost the big race, but t ..." />
    <meta name="keywords" content="slate" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=no">

    
    

    
    
    
    <script>
      
      var commercialNode = 'blogs/browbeat';
      
      var commercialPageType = 'article';
      var selectedText = "";
    </script>

    <!-- Facebook Pixel Code -->
    <script>
      !function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
      n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
      n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
      t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
      document,'script','https://connect.facebook.net/en_US/fbevents.js');

      fbq('init', '166975463695820');
      fbq('track', 'ViewContent', {
        commercial_node: window.commercialNode,
        referrer: document.referrer
      });
    </script>
    <!-- End Facebook Pixel Code -->

    <!-- Facebook OG -->
    <meta id="ogtitle" property="og:title" content="Seth Meyers Has More Embarrassing Trump Stories Than He Knows What to Do With" />
    

    <meta property="article:publisher" content="http://www.facebook.com/Slate" />
    <meta name="apple-itunes-app" content="app-id=357555242, affiliate-data=ct=Smart%20Banner&pt=31813800, app-argument=http://www.slate.com/blogs/browbeat/2017/07/18/seth_meyers_has_more_trump_scandals_than_he_knows_what_to_do_with.html">

    

    <meta property="og:type" content="article" />
    <meta id="ogurl" property="og:url" content="http://www.slate.com/blogs/browbeat/2017/07/18/seth_meyers_has_more_trump_scandals_than_he_knows_what_to_do_with.html" />
    <meta id="ogimage" property="og:image" content="http://www.slate.com/content/dam/slate/blogs/browbeat/2017/07/18/seth_meyers_has_more_trump_scandals_than_he_knows_what_to_do_with/170717_browbeat_meyers.jpg.CROP.promo-large.jpg" />
    <meta property="og:site_name" content="Slate Magazine" />
    <meta id="ogdescription" property="og:description" content="You know that scene at the end of the movie about the aging racehorse and the juvenile delinquent, where it seems like they&rsquo;ve lost the big race, but t ..." />
    <meta property="fb:app_id" content="142011022527753"/>
    <!-- Twitter -->
    <meta name="twitter:card" value="summary_large_image" />
    <meta name="twitter:site" value="@slate" />
    
    <meta name="twitter:creator" value="@matthewdessem" />
    
    <meta name="twitter:url" value="http://www.slate.com/blogs/browbeat/2017/07/18/seth_meyers_has_more_trump_scandals_than_he_knows_what_to_do_with.html" />
    <meta name="twitter:title" value="Seth Meyers Has More Embarrassing Trump Stories Than He Knows What to Do With" />
    <meta name="twitter:description" value="You know that scene at the end of the movie about the aging racehorse and the juvenile delinquent, where it seems like they&rsquo;ve lost the big race, but t ..." />
    <meta name="twitter:image" value="http://www.slate.com/content/dam/slate/blogs/browbeat/2017/07/18/seth_meyers_has_more_trump_scandals_than_he_knows_what_to_do_with/170717_browbeat_meyers.jpg.CROP.promo-large.jpg" />
    
    <meta name="tw-line" content="Seth Meyers has more embarrassing Trump stories than he knows what to do with:" />

      
    <meta name="fb-share" content="The President is pretending to drive trucks again." />

    

    <link type="text/css" href="http://static.cdnslate.com/etc/designs/slate/css/story.ae85d3d9.ae0b383f.css" rel="stylesheet" />

    
    
    
    <script id="slate-webfont-base-localstorage-js">!function(){function e(e,t,n){e.addEventListener?e.addEventListener(t,n,!1):e.attachEvent&&e.attachEvent("on"+t,n)}function t(e){return window.localStorage&&localStorage.font_base_css_cache&&localStorage.font_base_css_cache_file===e}function n(){if(window.localStorage&&window.XMLHttpRequest)if(t(o))a(localStorage.font_base_css_cache);else{var n=new XMLHttpRequest;n.open("GET",o,!0),e(n,"load",function(){4===n.readyState&&(a(n.responseText),localStorage.font_base_css_cache=n.responseText,localStorage.font_base_css_cache_file=o)}),n.send()}else{var c=document.createElement("link");c.href=o,c.rel="stylesheet",c.type="text/css",document.getElementsByTagName("head")[0].appendChild(c),document.cookie="font_base_css_cache"}}function a(e){var t=document.createElement("style");t.innerHTML=e,document.getElementsByTagName("head")[0].appendChild(t)}var o="http://static.cdnslate.com/etc/designs/slate/css/slate-fonts-base.bcb407b3.bcb407b3.css";window.localStorage&&localStorage.font_base_css_cache||document.cookie.indexOf("font_base_css_cache")>-1?n():e(document,"DOMContentLoaded",n)}();
      // Load Apres Light for Mobile
      if (window.matchMedia('(max-width: 1023px)').matches) {
        !function(){function e(e,t,n){e.addEventListener?e.addEventListener(t,n,!1):e.attachEvent&&e.attachEvent("on"+t,n)}function t(e){return window.localStorage&&localStorage.font_mobile_css_cache&&localStorage.font_mobile_css_cache_file===e}function n(){if(window.localStorage&&window.XMLHttpRequest)if(t(o))a(localStorage.font_mobile_css_cache);else{var n=new XMLHttpRequest;n.open("GET",o,!0),e(n,"load",function(){4===n.readyState&&(a(n.responseText),localStorage.font_mobile_css_cache=n.responseText,localStorage.font_mobile_css_cache_file=o)}),n.send()}else{var c=document.createElement("link");c.href=o,c.rel="stylesheet",c.type="text/css",document.getElementsByTagName("head")[0].appendChild(c),document.cookie="font_mobile_css_cache"}}function a(e){var t=document.createElement("style");t.innerHTML=e,document.getElementsByTagName("head")[0].appendChild(t)}var o="http://static.cdnslate.com/etc/designs/slate/css/slate-fonts-mobile.015046cd.015046cd.css";window.localStorage&&localStorage.font_mobile_css_cache||document.cookie.indexOf("font_mobile_css_cache")>-1?n():e(document,"DOMContentLoaded",n)}();
      }
    </script>
    <noscript id="slate-font-base"><link rel="stylesheet" id="slate-font-base-css" href="http://static.cdnslate.com/etc/designs/slate/css/slate-fonts-base.bcb407b3.bcb407b3.css" type="text/css" media="all"><link rel="stylesheet" id="slate-font-mobile-css" href="http://static.cdnslate.com/etc/designs/slate/css/slate-fonts-mobile.015046cd.015046cd.css" type="text/css" media="max-width: 1023px"></noscript>
    
    
    
    <script src="http://static.cdnslate.com/etc/designs/slate/js/optimizely-functions.dbf6a15e.js"></script>
    <script src="https://cdn.optimizely.com/js/37441550.js"></script>
    
    <script data-ad-site="slate" src="http://static.cdnslate.com/etc/designs/slate/js/libs/require.js"></script>
    <script>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</script>
    <script src="http://static.cdnslate.com/etc/designs/slate/js/main.min.10e41054.js"></script>
    <script>
    
    requirejs(['config'], function(config) {
      var documentDomain = 'slate.com';
      if (config.janrain.siteConfig.enabled) {
        documentDomain = config.myslate.site_base_domain;
      }
      document.domain = documentDomain;
    });
    
    </script>
    
    


<script type="text/javascript" language="javascript">
requirejs([
  'jquery',
  'config',
  's_code',
  'libs/jquery-plugins/jquery.cookie'
], function($, config, s, unused) {

        s.currencyCode="usd";
        s.charSet="utf-8";
        s.trackDownloadLinks=true;
        s.trackExternalLinks=true;
        s.trackInlineStats=true;
        s.linkDownloadFileTypes="exe,zip,wav,mp3,mov,mpg,avi,wmv,doc,pdf,xls";
        s.linkInternalFilters="javascript:,slate.com,traffic.outbrain.com";
        s.linkTrackVars="none";
        s.linkTrackEvents="none";
        s.pageName="arts:blog:brow beat - 20170718 - seth meyers has more trump scandals than he knows what to do with.";
        s.channel="sl - arts";
        s.server="www.slate.com";
        s.prop2="blog";
        s.prop3="blog";
        s.prop4="slate";
        s.prop5="matthew dessem";
        s.prop12="205170718002";
        s.prop13="seth meyers has more trump scandals than he knows what to do with.";
        s.prop14="1";
        s.prop25="brow beat";
        s.prop34="4.16.10";
        s.prop36="general";
        s.prop39="blogs/browbeat";
        s.prop40="television, late night tv, late night, seth meyers";
        s.hier1="arts|blog|blog";
        s.eVar8="matthew dessem";
        s.eVar11="brow beat";
        s.eVar17="blog";
    s.prop75 = "1";
    s.eVar4 = "1";
    s.prop32 = $.cookie('spf') || 'false';
    /**
     * Check for AdBlock
     */
    if (typeof placeAd2 === 'undefined') {
      $.cookie('spf', true, {
        expires: 365,
        path: '/',
        domain: config.myslate.site_base_domain
      });
    }
    s.t();
});
</script>


    
    
        <script>
            requirejs(["sgads"], function(slateads) {
                slateads.wire("http://ads.cdnslate.com/wp-srv/ad/loaders/latest/js/min/loader.min.js");
            });
        </script>
    

    <script>               
      var _isNavMoving = false; // acts as a global (sorry) mutex for keeping track of when our nav panels are moving around. Allows us to prevent overlapping actions.
    </script>

    <!-- Google Sitemap -->
    <meta name="google-site-verification" content="jXqoqqPSmx_PWchRdG-IXu-X616Ee2Ptf_AiElI9LzQ" />

    

    <link rel="canonical" href="http://www.slate.com/blogs/browbeat/2017/07/18/seth_meyers_has_more_trump_scandals_than_he_knows_what_to_do_with.html" />
    
    <link rel="image_src" href="http://www.slate.com/content/dam/slate/blogs/browbeat/2017/07/18/seth_meyers_has_more_trump_scandals_than_he_knows_what_to_do_with/170717_browbeat_meyers.jpg.CROP.thumbnail-small.jpg" />

    <!-- Parsely -->
        <meta name='parsely-page' content='{
  "title": "Seth Meyers Has More Embarrassing Trump Stories Than He Knows What to Do With",
  "link": "http://www.slate.com/blogs/browbeat/2017/07/18/seth_meyers_has_more_trump_scandals_than_he_knows_what_to_do_with.html",
  "image_url": "http://www.slate.com/content/dam/slate/blogs/browbeat/2017/07/18/seth_meyers_has_more_trump_scandals_than_he_knows_what_to_do_with/170717_browbeat_meyers.jpg.CROP.thumbnail-small.jpg",
  "type": "post",
  "post_id": "205170718002",
  "pub_date": "2017-07-18T01:24:23Z",
  "section": "Brow Beat",
  "authors": ["Matthew Dessem"],
  "tags": [
    "television",
    "late night tv",
    "late night",
    "seth meyers",
    "AdNode:blogs/browbeat",
    "Section:Arts"
  ]
}'/>
    
    <!-- RSS -->
    <link rel="alternate" type="application/rss+xml" title="Brow Beat (RSS 2.0)" href="http://www.slate.com/blogs/browbeat.fulltext.all.rss" />

    
    <script>var wp_meta_data = {"authors":["Matthew Dessem"],"contentType":"blog","page_id":"205170718002","keywords":"television,late night tv,late night,seth meyers,slate","section":"Arts","rubric":"Blog"};</script>

    
    <![if gte IE 8]>
    <script type="text/javascript">
    requirejs(['jquery'], function($) {
      var SlateNextbox = {};

      SlateNextbox.data = {
        'headline': 'It Turns Out <em>Ingrid Goes West <\/em>Is the Real <em>Emoji Movie<\/em>',
        'subhead': '',
        'url': 'http:\/\/www.slate.com\/blogs\/browbeat\/2017\/07\/18\/it_turns_out_ingrid_goes_west_is_the_real_emoji_movie.html',
        'article_id': '205170718001',
        'hasImage': true,
        
        'image': 'http:\/\/www.slate.com\/content\/dam\/slate\/blogs\/browbeat\/2017\/07\/18\/it_turns_out_ingrid_goes_west_is_the_real_emoji_movie\/170717_browbeat_igw.jpg.CROP.rectangle-small.jpg',
        
      
        'section': 'Brow Beat',
      
        'subscribe_type': 'rubric'
      };
      $.data(window, "SlateNextbox", SlateNextbox);
    });

    </script>
    <![endif]>
    

    

      
    
      <script type="text/javascript">
        var teadsEnabled = true;
        requirejs(["jquery","myslate"], function($,myslate) {
            if(myslate.isSlatePlusUser) {
                teadsEnabled = false;
            }
        });
        </script>
    
      
        <script type="application/ld+json">
        {"@context":"http://schema.org","url":"http://www.slate.com/blogs/browbeat/2017/07/18/seth_meyers_has_more_trump_scandals_than_he_knows_what_to_do_with.html","@type":"Article","mainEntityOfPage":"True","articleBody":"You know that scene at the end of the movie about the aging racehorse and the juvenile delinquent, where it seems like they\u2019ve lost the big race, but then on the final stretch the racehorse draws on reserves no one knew it had and just demolishes every record the track has ever seen? That\u2019s sort of what happened to Seth Meyers on Monday night. So far, Meyers has done a decent job of keeping pace with the president, but over the weekend, Trump easily outpaced Meyers and his staff, piling up so many embarrassments that even a 14-minute segment barely scratched the surface. Meyers could have gotten an entire \u201cCloser Look\u201d segment from Trump\u2019s weird love of playing make-believe with trucks\u2014this time it\u2019s a fire truck\u2014but add a photo opportunity in a cowboy hat and Trump\u2019s bizarre story about flying bags of heroin? That\u2019s what separates your Seabiscuits from your Santa\u2019s Little Helpers\u2014and that\u2019s even before Meyers even gets to Donald Trump Jr.\u2019s magical moving goalposts, ostensibly the subject of the segment. Meyers barely has time to fit in the nonsense Trump\u2019s supporters have been spewing\u2014by the time he rounds the first curve, the Trumps have finished their victory lap. It\u2019s a breathtaking display of natural athleticism, the kind of thing that might raise a nation\u2019s spirits in the depths of a Great Depression. As long as that nation isn\u2019t the United States.","headline":"Seth Meyers Has More Embarrassing Trump Stories Than He Knows What to Do With","datePublished":"2017-07-18T01:24:23-04:00","author":"Matthew Dessem","image":{"@list":["http://www.slate.com/content/dam/slate/blogs/browbeat/2017/07/18/seth_meyers_has_more_trump_scandals_than_he_knows_what_to_do_with/170717_browbeat_meyers.jpg.CROP.promo-mediumlarge.jpg"]}}
        </script>
      

    


    <!-- BEGIN Krux Control Tag for "Slate" -->
    <script class="kxct" data-id="KGU_SbHX" data-timing="async" data-version="3.0" type="text/javascript">
      window.Krux||((Krux=function(){Krux.q.push(arguments)}).q=[]);
      (function(){
        var k=document.createElement('script');k.type='text/javascript';k.async=true;
        k.src=(location.protocol==='https:'?'https:':'http:')+'//cdn.krxd.net/controltag/KGU_SbHX.js';
        var s=document.getElementsByTagName('script')[0];s.parentNode.insertBefore(k,s);
      }());

      
      window.Krux||((Krux=function(){Krux.q.push(arguments);}).q=[]);
      (function(){
          function retrieve(n){
            var m, k='kxslate_'+n;
            if(window.localStorage){
                return window.localStorage[k] || "";
            }else if(navigator.cookieEnabled){
                m = document.cookie.match(k+'=([^;]*)');
                return (m && unescape(m[1])) || "";
            }else{
                return '';
            }
          }
          Krux.user = retrieve('user');
          Krux.segments = retrieve('segs') && retrieve('segs').split(',') || [];
      })();
    </script>
    <!-- END Krux Controltag -->

    
    <link rel="amphtml" href="http://amp.slate.com/blogs/browbeat/2017/07/18/seth_meyers_has_more_trump_scandals_than_he_knows_what_to_do_with.html">
    
  </head>



  <body class="article story">

    <input type="hidden" id="currPath" value="/blogs/browbeat/2017/07/18/seth_meyers_has_more_trump_scandals_than_he_knows_what_to_do_with"/>
    <!-- HCS: shared/roll_ups/tablet -->
    <!-- This is the header bar we always show in tablet mode -->
    <header class="roll-up" id="tablet_header">
      <div class="container">
        <div class="main">

        </div>
        <div class="sidebar">
          








<section class="nav-panel" >
  <div class="nav-header">
    <a class="slate-logo" href="/"><span class="logo">Slate</span></a>
    <a href="#" class="user-link "></a>
    <a href="#" class="search-link "></a>
    <a href="#" class="global-nav-handle "></a>
    <div class="buttons">
      
      <span class="link option"><a class="first nav-option sign-in-link" href="#">Sign In</a></span>
      <span class="link option"><a href="#" class="nav-option sign-up-link">Sign Up</a></span>
      
    </div>
  </div>
  
</section>

        </div>
      </div><!-- /.container -->
    </header><!-- /.header.roll-up -->
    <!-- HCS END: shared/roll_ups/tablet -->
    
    <div class="top">

      
        
          <div class="ad banner leaderboard" data-ad-type="leaderboard" data-ad-mode="large"></div>
        
        
      

    </div><!-- end #top -->
    
    <!-- HCS END: layouts/shared/top -->
    
    
    


<!-- this is the rollup for basic article, no multipart fun -->
<header class="roll-up with-dropdown" id="article_rollup">
  <div class="container">
    
    <div class="main">
      <div class="title-container">

        <div class="front">
          
            
            
            
            
            
              <div class="titles centered-titles">
                <h1 class="primary centered-primary">Seth Meyers Has More Embarrassing Trump Stories Than He Knows What to Do With</h1>
              </div>
            
          
        </div>

        <div class="back">
          
            
            
            
            
              <div class="titles centered-titles">
                <h1 class="primary centered-primary">Seth Meyers Has More Embarrassing Trump Stories Than He Knows What to Do With</h1>
              </div>
            
          
        </div>

      </div>

      


<div class="social social-with-popup sharing-buttons">
    <a href="#" data-share="http://www.facebook.com/sharer.php?s=100&p[title]=Seth+Meyers+Has+More+Embarrassing+Trump+Stories+Than+He+Knows+What+to+Do+With&p[summary]=You+know+that+scene+at+the+end+of+the+movie+about+the+aging+racehorse+and+the+juvenile+delinquent,+where+it+seems+like+they&rsquo;ve+lost+the+big+race,+but+t+...&p[ref]=sl_live&p[images][0]=http://www.slate.com/content/dam/slate/blogs/browbeat/2017/07/18/seth_meyers_has_more_trump_scandals_than_he_knows_what_to_do_with/170717_browbeat_meyers.jpg.CROP.cq5dam_web_1280_1280_jpeg.jpg&p[url]=http://www.slate.com/blogs/browbeat/2017/07/18/seth_meyers_has_more_trump_scandals_than_he_knows_what_to_do_with.html&u=http://www.slate.com/blogs/browbeat/2017/07/18/seth_meyers_has_more_trump_scandals_than_he_knows_what_to_do_with.html?wpsrc=sh_all_dt_fb_ru" class="facebook first">
      <span class="icon"></span>
      <span class="count"></span>
    </a>

    <div class="twitter">
    <a href="#" data-share="http://twitter.com/share?text=Seth%20Meyers%20has%20more%20embarrassing%20Trump%20stories%20than%20he%20knows%20what%20to%20do%20with%3A&count=none&via=BrowBeat&url=http://www.slate.com/blogs/browbeat/2017/07/18/seth_meyers_has_more_trump_scandals_than_he_knows_what_to_do_with.html?wpsrc=sh_all_dt_tw_ru" class="twitter">
      <span class="icon"></span>
      <span class="count"></span>
    </a>
    </div>

    
      <a href="#comments" class="comments">
        <span class="icon"></span>
      </a>
    

     <a href="mailto:?subject=Check%20out%20this%20piece%20on%20Slate&body=I%20thought%20you%20might%20like%20this%20article%20on%20Slate:%0ASeth%20Meyers%20Has%20More%20Embarrassing%20Trump%20Stories%20Than%20He%20Knows%20What%20to%20Do%20With%0Ahttp://www.slate.com/blogs/browbeat/2017/07/18/seth_meyers_has_more_trump_scandals_than_he_knows_what_to_do_with.html?wpsrc=sh_all_dt_em_ru" class="email">
        <span class="icon"></span>
      </a>
</div>


    </div>
    <div class="sidebar">
      








<section class="nav-panel" >
  <div class="nav-header">
    <a class="slate-logo" href="/"><span class="logo">Slate</span></a>
    <a href="#" class="user-link "></a>
    <a href="#" class="search-link "></a>
    <a href="#" class="global-nav-handle "></a>
    <div class="buttons">
      
      <span class="link option"><a class="first nav-option sign-in-link" href="#">Sign In</a></span>
      <span class="link option"><a href="#" class="nav-option sign-up-link">Sign Up</a></span>
      
    </div>
  </div>
  
</section>

    </div>
  </div><!-- /.container -->
  <a href="#" class="mobile-social-toggle"><span></span></a> <!-- only shown in mobile -->
</header><!-- /.header.roll-up -->




<div class="page">
  
  <article class="main" data-stream-index="0" data-story-id="story-205170718002" id="story-0">
    
    <div class="start-story" data-stream-index="0" id="start-story-0"></div>
    
    
    <div class="parsys contentWellTop iparsys"><div class="section"><div class="new"></div>
</div><div class="iparys_inherited"><div class="parsys contentWellTop iparsys"><div class="renderHtml section">

<style>
@media (min-width: 641px) {
.custom .landing-header.thin.rollup .sponsor-logo img {
    height: 25px;
    width: auto;
}
}

@media (max-width: 640px) {
.custom .landing-header.thin.rollup .sponsor-logo img {
    height: auto;
    max-width: 100px;
    position: absolute;
    right: auto;
    top: 15px;
    left: 155px;
}
}
</style> 
</div>

</div>
</div>
</div>

    

    <header class="article-header" id="article_header">
      <div class="meta has-image">
        <div class="prop-name print-only"><a href="http://www.slate.com">Slate</a></div><div class="prop-name"><a href="http://www.slate.com/blogs/browbeat.html">Brow Beat</a></div><div class="prop-image"><a href="http://www.slate.com/blogs/browbeat.html"><img src="/blogs/browbeat/jcr:content/logo.gif" alt="Brow Beat" /></a></div><div class="prop-desc">Slate's Culture Blog</div><div class="pub-date">July 18 2017 1:24 AM</div>
      </div>
      <h1 class="hed">Seth Meyers Has More Embarrassing Trump Stories Than He Knows What to Do With</h1>
      


 <div class="social social-with-popup sharing-buttons header_social">
    <a href="#" data-share="http://www.facebook.com/sharer.php?s=100&p[title]=Seth+Meyers+Has+More+Embarrassing+Trump+Stories+Than+He+Knows+What+to+Do+With&p[summary]=You+know+that+scene+at+the+end+of+the+movie+about+the+aging+racehorse+and+the+juvenile+delinquent,+where+it+seems+like+they&rsquo;ve+lost+the+big+race,+but+t+...&p[ref]=sl_live&p[images][0]=http://www.slate.com/content/dam/slate/blogs/browbeat/2017/07/18/seth_meyers_has_more_trump_scandals_than_he_knows_what_to_do_with/170717_browbeat_meyers.jpg.CROP.cq5dam_web_1280_1280_jpeg.jpg&p[url]=http://www.slate.com/blogs/browbeat/2017/07/18/seth_meyers_has_more_trump_scandals_than_he_knows_what_to_do_with.html?wpsrc=sh_all_dt_fb_top" class="facebook">
      <span class="icon"></span>
      <span class="count"></span>
    </a>
    <div class="twitter">
    <a href="#" data-share="http://twitter.com/share?text=Seth%20Meyers%20has%20more%20embarrassing%20Trump%20stories%20than%20he%20knows%20what%20to%20do%20with%3A&count=none&via=BrowBeat&url=http://www.slate.com/blogs/browbeat/2017/07/18/seth_meyers_has_more_trump_scandals_than_he_knows_what_to_do_with.html?wpsrc=sh_all_dt_tw_top" class="twitter">
       <span class="icon"></span>
    </a>
    <a class="tw-count" href="http://twitter.com/search?q=http://www.slate.com/blogs/browbeat/2017/07/18/seth_meyers_has_more_trump_scandals_than_he_knows_what_to_do_with.html"><span class="count"></span></a>
    </div>
    
      <a href="#comments" class="comments">
        <span class="icon"></span>
        <span class="count"></span>
      </a>
    
 </div>


      <h2 class="dek"></h2>
      
      <div class="byline" id="main_byline">
      
        By <a href="http://www.slate.com/authors.matthew_dessem.html">Matthew Dessem</a>
      
      </div>
      
      





  
  
  


<div class="social horiz-counts-mobile centered sharing-buttons">
  
    <div class="comments">
      <a class="mobile-comments" href="#comments">
        <span class="icon"></span>
        <span class="count"></span>
      </a>
    </div>
  
  <div class="facebook">
    <a href="#" data-share="http://www.facebook.com/sharer.php?s=100&p[title]=Seth+Meyers+Has+More+Embarrassing+Trump+Stories+Than+He+Knows+What+to+Do+With&p[summary]=You+know+that+scene+at+the+end+of+the+movie+about+the+aging+racehorse+and+the+juvenile+delinquent,+where+it+seems+like+they&rsquo;ve+lost+the+big+race,+but+t+...&p[ref]=sl_live&p[images][0]=http://www.slate.com/content/dam/slate/blogs/browbeat/2017/07/18/seth_meyers_has_more_trump_scandals_than_he_knows_what_to_do_with/170717_browbeat_meyers.jpg.CROP.cq5dam_web_1280_1280_jpeg.jpg&p[url]=http://www.slate.com/blogs/browbeat/2017/07/18/seth_meyers_has_more_trump_scandals_than_he_knows_what_to_do_with.html&u=http://www.slate.com/blogs/browbeat/2017/07/18/seth_meyers_has_more_trump_scandals_than_he_knows_what_to_do_with.html?wpsrc=sh_all_mob_fb_top" class="share facebook" target="_blank">
      <span class="icon"></span>
      <span class="count"></span>
    </a>
  </div>
  <div class="twitter">
    <a href="#" data-share="http://twitter.com/share?text=Seth%20Meyers%20has%20more%20embarrassing%20Trump%20stories%20than%20he%20knows%20what%20to%20do%20with%3A&count=none&via=BrowBeat&url=http://www.slate.com/blogs/browbeat/2017/07/18/seth_meyers_has_more_trump_scandals_than_he_knows_what_to_do_with.html?wpsrc=sh_all_mob_tw_top" class="twitter">
       <span class="icon"></span>
    </a>
    <a class="tw-count" href="http://twitter.com/search?q=http://www.slate.com/blogs/browbeat/2017/07/18/seth_meyers_has_more_trump_scandals_than_he_knows_what_to_do_with.html"><span class="count"></span></a>
  </div>

  
  <div class="whatsapp">
    <a href="whatsapp://send?text=Seth%20Meyers%20has%20more%20embarrassing%20Trump%20stories%20than%20he%20knows%20what%20to%20do%20with%3A%20http%3A%2F%2Fwww.slate.com%2Fblogs%2Fbrowbeat%2F2017%2F07%2F18%2Fseth_meyers_has_more_trump_scandals_than_he_knows_what_to_do_with.html%3Fwpsrc%3Dsh_all_mob_wa_top" class="whatsapp">
       <span class="icon"></span>
    </a>
  </div>
  
  

  <div class="email">
    <a href="mailto:?subject=Check%20out%20this%20piece%20on%20Slate&body=I%20thought%20you%20might%20like%20this%20article%20on%20Slate:%0ASeth%20Meyers%20Has%20More%20Embarrassing%20Trump%20Stories%20Than%20He%20Knows%20What%20to%20Do%20With%0Ahttp://www.slate.com/blogs/browbeat/2017/07/18/seth_meyers_has_more_trump_scandals_than_he_knows_what_to_do_with.html?wpsrc=sh_all_mob_em_top" class="email">
      <span class="icon"></span>
      <span class="count">&nbsp;</span>
    </a>
  </div>
</div>


    </header><!-- /header -->

    <section class="content ">
        <div class="parsys editorsNote">
</div>

        
        <div class="newbody body parsys">

<div class="parbase image slate_image section">


 <div class=" desktop-only mobile-only">
        <figure class="image inline " style="width: 590px;  display: block;margin: 0 auto;float: none;"> <img src_tag_name="src" title="170717_browbeat_meyers" alt="170717_browbeat_meyers" src="/content/dam/slate/blogs/browbeat/2017/07/18/seth_meyers_has_more_trump_scandals_than_he_knows_what_to_do_with/170717_browbeat_meyers.jpg.CROP.promo-xlarge2.jpg" > <figcaption class="caption"><span>Fire truck!</span></figcaption>  <p class="credit">NBC</p> 
        </figure>
        </div>
        <script>
        requirejs(["jquery"], function($) {
            if ($(window).width() < 640) {
                $(".slate_image figure").width("100%");
            }
        });
        </script> 
</div>

<div class="thirdpartyvideo section">


  
  
    <div class="youtube-responsive">

    <div id="thirdpartyvideo" data-video-bcenabled="false" data-video-type="youtube" data-video-bcbasepageurl="http://www.slate.com/blogs/browbeat/2017/07/18/seth_meyers_has_more_trump_scandals_than_he_knows_what_to_do_with/_jcr_content/body.html" data-video-bcexperienceid="0" data-video-bcvideoid="" data-video-bcplaylistid="" data-video-width="590" data-video-height="332" data-video-youtubeid="EBGJqZHsdJ0" data-video-autoplay="0"></div>
    <script type="text/javascript">
      // load youtube scripts once all components have rendered,
      // this will then call onYouTubeIframeAPIReady in youtube require include to load videos
      requirejs(['jquery','bcvideo'], function($,bcvideo) {
        $(document).ready(function() {
          requirejs(['youtube','youtubeapi'], function(youtube) { });
        });
      });
    </script>

    </div>
  
  
</div>

<div class="text text-1 parbase section">

<p>You know that scene at the end of the movie about the aging racehorse and the juvenile delinquent, where it seems like they&rsquo;ve lost the big race, but then on the final stretch the racehorse draws on reserves no one knew it had and just demolishes every record the track has ever seen? That&rsquo;s sort of what happened to Seth Meyers on Monday night. So far, Meyers has done a decent job of keeping pace with the president, but over the weekend, Trump easily outpaced Meyers and his staff, piling up so many embarrassments that even a 14-minute segment barely scratched the surface.</p>


</div>


<div class="text-2 text parbase section">

<p>Meyers could have gotten an entire &ldquo;Closer Look&rdquo; segment from Trump&rsquo;s weird love of playing make-believe with trucks&mdash;this time it&rsquo;s a fire truck&mdash;but add a photo opportunity in a cowboy hat <em>and </em>Trump&rsquo;s bizarre story about flying bags of heroin? That&rsquo;s what separates your Seabiscuits from your Santa&rsquo;s Little Helpers&mdash;and that&rsquo;s even before Meyers even gets to Donald Trump Jr.&rsquo;s <a href="http://www.slate.com/articles/news_and_politics/politics/2017/07/all_the_damning_trumpworld_excuses_for_the_don_jr_meeting.html">magical moving goalposts</a>, ostensibly the subject of the segment. Meyers barely has time to fit in the nonsense Trump&rsquo;s supporters have been spewing&mdash;by the time he rounds the first curve, the Trumps have finished their victory lap. It&rsquo;s a breathtaking display of natural athleticism, the kind of thing that might raise a nation&rsquo;s spirits in the depths of a Great Depression. As long as that nation isn&rsquo;t the United States.</p>


</div>
</div>

        
        
        
    </section>
    <div class="end-story" data-stream-index="0" id="end-story-0"></div>
<footer>
      
		


  
  <section class="about-the-author multi">
    
    <div class="author-bio">
      <p>
        <p><a href="https://twitter.com/matthewdessem">Matthew Dessem</a> is Brow Beat’s nights and weekends editor and the author of a <a href="http://www.amazon.com/dp/1941629199/?tag=slatmaga-20">biography of screenwriter and director Clyde Bruckman</a>.</p>

	  </p>
	</div>
	
  </section>
  

      

  
  

      


    <div class="social social-with-popup sharing-buttons social-footer">

      <a href="#" data-share="http://www.facebook.com/sharer.php?s=100&p[title]=Seth+Meyers+Has+More+Embarrassing+Trump+Stories+Than+He+Knows+What+to+Do+With&p[summary]=You+know+that+scene+at+the+end+of+the+movie+about+the+aging+racehorse+and+the+juvenile+delinquent,+where+it+seems+like+they&rsquo;ve+lost+the+big+race,+but+t+...&p[ref]=sl_live&p[images][0]=http://www.slate.com/content/dam/slate/blogs/browbeat/2017/07/18/seth_meyers_has_more_trump_scandals_than_he_knows_what_to_do_with/170717_browbeat_meyers.jpg.CROP.cq5dam_web_1280_1280_jpeg.jpg&p[url]=http://www.slate.com/blogs/browbeat/2017/07/18/seth_meyers_has_more_trump_scandals_than_he_knows_what_to_do_with.html?wpsrc=sh_all_dt_fb_bot" class="facebook">
        <span class="icon"></span>
        <span class="count"></span>
      </a>
    <div class="twitter">
    <a href="#" data-share="http://twitter.com/share?text=Seth%20Meyers%20has%20more%20embarrassing%20Trump%20stories%20than%20he%20knows%20what%20to%20do%20with%3A&count=none&via=BrowBeat&url=http://www.slate.com/blogs/browbeat/2017/07/18/seth_meyers_has_more_trump_scandals_than_he_knows_what_to_do_with.html?wpsrc=sh_all_dt_tw_bot" class="twitter">
       <span class="icon"></span>
    </a>
    <a class="tw-count" href="http://twitter.com/search?q=http://www.slate.com/blogs/browbeat/2017/07/18/seth_meyers_has_more_trump_scandals_than_he_knows_what_to_do_with.html"><span class="count"></span></a>
    </div>
      
        <a href="#comments" class="comments">
          <span class="icon"></span>
          <span class="count"></span>
        </a>
      
    </div>



    






  
  
  

<div class="social horiz-counts-mobile centered sharing-buttons">
  
    <div class="comments">
      <a class="mobile-comments" href="#comments">
        <span class="icon"></span>
        <span class="count"></span>
      </a>
    </div>
  
  <div class="facebook">
    <a href="#" data-share="http://www.facebook.com/sharer.php?s=100&p[title]=Seth+Meyers+Has+More+Embarrassing+Trump+Stories+Than+He+Knows+What+to+Do+With&p[summary]=You+know+that+scene+at+the+end+of+the+movie+about+the+aging+racehorse+and+the+juvenile+delinquent,+where+it+seems+like+they&rsquo;ve+lost+the+big+race,+but+t+...&p[ref]=sl_live&p[images][0]=http://www.slate.com/content/dam/slate/blogs/browbeat/2017/07/18/seth_meyers_has_more_trump_scandals_than_he_knows_what_to_do_with/170717_browbeat_meyers.jpg.CROP.cq5dam_web_1280_1280_jpeg.jpg&p[url]=http://www.slate.com/blogs/browbeat/2017/07/18/seth_meyers_has_more_trump_scandals_than_he_knows_what_to_do_with.html&u=http://www.slate.com/blogs/browbeat/2017/07/18/seth_meyers_has_more_trump_scandals_than_he_knows_what_to_do_with.html?wpsrc=sh_all_mob_fb_bot" class="share facebook" target="_blank">
      <span class="icon"></span>
      <span class="count"></span>
    </a>
  </div>
  <div class="twitter">
    <a href="#" data-share="http://twitter.com/share?text=Seth%20Meyers%20has%20more%20embarrassing%20Trump%20stories%20than%20he%20knows%20what%20to%20do%20with%3A&count=none&via=BrowBeat&url=http://www.slate.com/blogs/browbeat/2017/07/18/seth_meyers_has_more_trump_scandals_than_he_knows_what_to_do_with.html?wpsrc=sh_all_mob_tw_bot" class="twitter">
       <span class="icon"></span>
    </a>
    <a class="tw-count" href="http://twitter.com/search?q=http://www.slate.com/blogs/browbeat/2017/07/18/seth_meyers_has_more_trump_scandals_than_he_knows_what_to_do_with.html"><span class="count"></span></a>
  </div>

  
  
  <div class="whatsapp">
    <a href="whatsapp://send?text=Seth%20Meyers%20has%20more%20embarrassing%20Trump%20stories%20than%20he%20knows%20what%20to%20do%20with%3A%20http%3A%2F%2Fwww.slate.com%2Fblogs%2Fbrowbeat%2F2017%2F07%2F18%2Fseth_meyers_has_more_trump_scandals_than_he_knows_what_to_do_with.html%3Fwpsrc%3Dsh_all_mob_wa_bot" class="whatsapp">
       <span class="icon"></span>
    </a>
  </div>
  

  <div class="email">
    <a href="mailto:?subject=Check%20out%20this%20piece%20on%20Slate&body=I%20thought%20you%20might%20like%20this%20article%20on%20Slate:%0ASeth%20Meyers%20Has%20More%20Embarrassing%20Trump%20Stories%20Than%20He%20Knows%20What%20to%20Do%20With%0Ahttp://www.slate.com/blogs/browbeat/2017/07/18/seth_meyers_has_more_trump_scandals_than_he_knows_what_to_do_with.html?wpsrc=sh_all_mob_em_bot" class="email">
      <span class="icon"></span>
      <span class="count">&nbsp;</span>
    </a>
  </div>
</div>


  
</footer>





<div id="comments" class="comments-container" data-lf-hash="MzM3NzIwOmNxLTIwNTE3MDcxODAwMg==">
  <div id="livefyre">
  	<div class="button-container lf-loader" style="text-align:center;">
      <button class="push-button comments-push-button" style="padding: 0 15px;">Load Comments</button>
    </div>
  </div>
  <div id="powered_by_livefyre_new"><a href="http://livefyre.com" target="_blank">Powered by Livefyre</a></div>
</div>

<div id="right-rail">
  <div id="comments-ads" class="comments-ads-container">
  </div>
  <div id="comments-bigbox" class="comments-bigbox-container">
    <div class="ad bigbox" data-ad-mode="desktop" data-ad-type="bigbox"></div>
  </div>
</div>

<script type="text/javascript">
requirejs(['config', 'jquery', 'slatelivefyre'], function(config, $, slatelivefyre) {
  $('#livefyre .lf-loader').html([
    '<div style="color: #999;">Loading...</div>',
    '<div style="color: #999; font-size: smaller; margin: 20px auto">',
    'Are Slate\'s comments not loading even after a few seconds? ',
    '<br/><a target="_blank" href="http://www.slate.com/features/browser-data-comment.html" class="issue-collector" data-issue-collector-value="11019">',
    'Send us your browser and operating system information.</a>',
    '</div>'
  ].join(''));

  $.extend(config.livefyre, {
    collectionMeta: 'eyJhbGciOiJIUzI1NiJ9.eyJ0aXRsZSI6IlNldGggTWV5ZXJzIEhhcyBNb3JlIEVtYmFycmFzc2luZyBUcnVtcCBTdG9yaWVzIFRoYW4gSGUgS25vd3MgV2hhdCB0byBEbyBXaXRoIiwidXJsIjoiaHR0cDovL3d3dy5zbGF0ZS5jb20vYmxvZ3MvYnJvd2JlYXQvMjAxNy8wNy8xOC9zZXRoX21leWVyc19oYXNfbW9yZV90cnVtcF9zY2FuZGFsc190aGFuX2hlX2tub3dzX3doYXRfdG9fZG9fd2l0aC5odG1sP3dwaXNyY1x1MDAzZGxmIiwidGFncyI6InRlbGV2aXNpb24sbGF0ZSBuaWdodCB0dixsYXRlIG5pZ2h0LHNldGggbWV5ZXJzIiwiY2hlY2tzdW0iOiJlOTNhYmY3MWZiM2IzYjg5YmViZGQ3YTFjYWQ2YjdjZCIsImFydGljbGVJZCI6ImNxLTIwNTE3MDcxODAwMiJ9.M1jSYsnMlGNOmSQu-Woa_FtvmO1qu5v8Bhayule55MU'
  });

  if (config.iscroll.disabled) {
    slatelivefyre.loadLivefyre(config.page.articleId, config.livefyre.collectionMeta);
  }
});
</script>




    <div class="parsys iparsys contentWellBottom"><div class="section"><div class="new"></div>
</div><div class="iparys_inherited"><div class="parsys iparsys contentWellBottom">
</div>
</div>
</div>

    

    
    <div class="noAutoRefresh" data-ad-type="teads" data-ad-mode="all" id="slug_teads"></div>
    <div class="bottom" id="bottom-0">
    </div>
    

  </article><!-- /.main -->
  
  <aside class="sidebar" id="main_sidebar">
    <div class="sidebar-wrapper">
      
      
      
      







  
  
  


<section class="nav-panel" id='slate_logo'>
  <div class="nav-header">
    <a class="slate-logo" href="/"><span class="logo">Slate</span></a>
    <a href="#" class="user-link sidebar-handle"></a>
    <a href="#" class="search-link sidebar-handle"></a>
    <a href="#" class="global-nav-handle sidebar-handle"></a>
    <div class="buttons">
      
      <span class="link option"><a class="first nav-option sign-in-link" href="#">Sign In</a></span>
      <span class="link option"><a href="#" class="nav-option sign-up-link">Sign Up</a></span>
      
    </div>
  </div>
  
</section>

      

      
      

<div class="parsys iparsys contentSidebar"><div class="section"><div class="new"></div>
</div><div class="iparys_inherited"><div class="parsys iparsys contentSidebar"><div class="rightrailstories section">

<section class="items">
  

  

  
 </section>


 
<script type="text/javascript">
requirejs(['jquery'], function($) {
  if (mobileMode()) {
    $(".rightrailstories section").remove();
  }
});
</script>



</div>

</div>
</div>
</div>



      
    </div><!-- /.sidebar-wrapper -->
  </aside><!-- /.sidebar -->
  
  
  
  	

  <footer id="article_footer_tiles">
     
  </footer>

  
</div><!-- /.page -->



<!-- HCS: layout -->
  
    <style type="text/css">
      body > .bottom {
        text-align: center;
        padding: 10px 0;
      }
      .bottom > #slug_leaderboard_2 {
        position: relative;
        width: auto;
        text-align: center;
      }
    </style>

    
      <div class="bottom">
        
          
            <div class="ad leaderboard-3" data-ad-type="leaderboard|3" data-ad-mode="desktop"></div>
          
          
        
      </div>
    



<footer class="slate-footer slate-footer--top">
  <div class="container">
    <div class="slate-footer__follow-slate">
          <span class="label">FOLLOW SLATE</span>
          <ul class="list-unstyled slate-footer__social-icons">
            <li class="twitter">
              <a href="https://twitter.com/slate" target="_blank"><span class="sr-only">Twitter</span></a>
            </li>
            <li class="facebook">
              <a href="http://www.facebook.com/Slate" target="_blank"><span class="sr-only">Facebook</span></a>
            </li>
            <li class="instagram">
              <a href="https://instagram.com/slate" target="_blank"><span class="sr-only">Instagram</span></a>
            </li>
          </ul>
    </div>

    <div id="slug_interstitial" data-ad-type="interstitial" data-ad-mode="all" style="display: none;"></div>

    <div class="slate-footer__slate-on">
      <span class="label">SLATE ON</span>
      <ul class="list-unstyled">
        <li><a href="http://itunes.apple.com/us/app/slate-com/id357555242?mt=8">IPHONE</a></li>
        <li><a href="https://market.android.com/details?id=com.wapo.slate.android">ANDROID</a></li>
        <li><a href="http://www.amazon.com/gp/product/B000IOMTC0?ie=UTF8&tag=slatmaga-20&link_code=as3&camp=211189&creative=373489&creativeASIN=B000IOMTC0/">KINDLE</a></li>
      </ul>
    </div>

    <ul class="slate-footer__reprints list-unstyled">
      <li><a href="http://www.slatereprints.com">Reprints</a></li>
      <li><a href="mailto:advertise@slate.com">Advertise with us</a></li>
    </ul>

  </div><!-- close wrapper -->
</footer><!-- footer base -->



  


<footer class="slate-footer slate-footer--bottom">
  <div class="container">
      <div class="slate-footer__links">
        <ul class="list-unstyled">
          <li><a href="/articles/news_and_politics/slate_fare/2006/08/about_us.html">ABOUT US</a></li>
          <li><a href="/articles/briefing/contact_us/2006/08/whereto_find_slate_staff.html">CONTACT US</a></li>
          <li><a href="/articles/news_and_politics/slate_fare/2008/04/a_job_for_you_at_slate.html">WORK WITH US</a></li>
          <li><a href="/articles/briefing/slate_user_agreement_and_privacy_policy/2012/12/slate_s_terms_of_service.html">USER AGREEMENT</a></li>
          <li><a href="/articles/briefing/slate_user_agreement_and_privacy_policy/2012/12/slate_s_privacy_policy.html">PRIVACY POLICY</a></li>
          <li><a href="/articles/briefing/slate_fare/2011/12/commenting_on_slate_frequently_asked_questions.html">FAQ</a></li>
        </ul>
        <ul class="list-unstyled">
          <li><a href="mailto:feedback@slate.com">FEEDBACK</a></li>
          <li><a href="/articles/news_and_politics/corrections.html">CORRECTIONS</a></li>
        </ul>
      </div><!-- -->

      <a href="http://www.slate.com" class="slate-group-logo">
        <span class="sr-only">Slate Group</span>
      </a>

      <a href="http://www.panoply.fm" class="panoply-logo" target="_blank">
        <span class="sr-only">Panoply</span>
      </a>

      <p class="copyright">Slate is published by The Slate Group, a Graham Holdings Company. All contents &copy;
        2017  The Slate Group LLC. All rights reserved.</p>

  </div><!-- close wrapper -->
</footer> <!-- /.footer-base-toc -->






<!-- HCS END: layout -->
<!-- HCS: layouts/shared/bottom -->

<div id="signIn"></div>
<script>


requirejs(["jquery", "hcs/libs/iscroll-lite", "modernizr", "hcs/script", "hcs/plugins/SGGlobalNav.jquery", "hcs/plugins/jQuery.highlighter","hcs/plugins/SGGlobalNav.jquery","libs/jquery-plugins/jquery.timeago","announcements","myslate"], function($, iScroll, unused0, unused1, unused2, unused3, unused4, unused5, announcements, myslate) {
  $(document).ready(function() {
    announcements.deleteOldCookies();
    
    $("span.timeago").timeago();
  });
  function pageLoadedForScrolling(){


    scroller = new iScroll('main_sidebar', {
      hScroll: false,
      hScrollbar: false,
      bounce: false
    });

    if(!mobileMode() && tabletMode() && $('html').hasClass('touch')){
      // Nav gets iScroll if we're on an actual tablet.
      window.tabletScroller = new iScroll('nav_sections', {
        hScroll: false,
        hScrollbar: false,
        bounce: false,
        onBeforeScrollStart: function (e) {
          var target = e.target;
          while (target.nodeType != 1) target = target.parentNode;

          if (target.tagName != 'SELECT' && target.tagName != 'INPUT' && target.tagName != 'TEXTAREA')
          e.preventDefault();
        }
      });
    }

  }

  // We institute fancy scrolling on iscroll only on mobile webkit.

  // Webkit detection script
  Modernizr.addTest('webkit', function(){
    return RegExp(" AppleWebKit/").test(navigator.userAgent);
  });

  // Mobile Webkit
  Modernizr.addTest('mobile', function(){
    return RegExp(" Mobile/").test(navigator.userAgent);
  });

  if(Modernizr.webkit && Modernizr.mobile){
    if (document.addEventListener){
      document.addEventListener('DOMContentLoaded', function () { setTimeout(pageLoadedForScrolling, 200); }, false);
    } else if (document.attachEvent){
      document.attachEvent('DOMContentLoaded', function () { setTimeout(pageLoadedForScrolling, 200); }, false);
    }
  }



  $(function(){

    if ($('body').hasClass('home')
        || $('body').hasClass('landing')
        || $('body').hasClass('settings')) {
      $('.nav-header').SGGlobalNav({
        noRollup: true, // Need to tell the homepage and landing etc that there's no rollup here, which causes things to behave differently.
        noBurgerScroll: $('body').hasClass('no-burger-scroll'),
        isSlatePlusUser: myslate.isSlatePlusUser
      });
    } else {
      $('.nav-header').SGGlobalNav({
        isSlatePlusUser: myslate.isSlatePlusUser
      });
    }


    // Input field placeholder plugin to account for placeholder fallbacks.
    jQuery(document).ready(function($) {
      $(".field-with-placeholder").placeholder();
    });


    $('.content').highlighter({
      'selector': '.highlighter-container',
      'noHighlightIds': $('#podcast-slateplus-page'),
      'minWords': 0,
      'complete': function (data) {
        // Here we have the selected string for use.
        // console.log(data);
        selectedText = data;
      }
    });

  });


  $(document).ready(function() {
    $(".sticky").each(function() {
      var stickyTop = $(".sticky").offset().top; // returns number
      $(window).scroll(function() { // scroll event
        var windowTop = $(window).scrollTop() + 57 + parseInt($(".sticky").css("margin-top").split("px")[0]); // returns number
        if (stickyTop < windowTop) {
          $(".sticky").css({ position: "fixed", top: "53px" });
        } else {
          $(".sticky").css("position","static");
        }
      });
    })
  });

  watchSocialWelcomeNotifications();

});
    </script>

    
    

    <script>
requirejs(["jquery", "myslate", "hcs/script", "hcs/plugins/SGNavDropdown.jquery",
		"hcs/plugins/SGBigSlider.jquery","hcs/plugins/SGFootnote.jquery","hcs/plugins/SGRollup.jquery",
		"hcs/plugins/SGNavDropdown.jquery","hcs/plugins/SGLightbox.jquery"],
		function($, myslate, unused0, unused1, unused2, unused3, unused4, unused5, unused6) {

    $(function(){

      $('.footnote').SGFootnote();
      var multipartArticleRollup = $('#article_rollup');

      var subHed = $('#sub_hed');
      if(subHed.length > 0){
        subHed.SGNavDropdown({ // Multipart rollup triggered by tapping the subhed.
          extraId: 'subhed', // Used to name events inside the plugin, so we can be sure to bind/unbind the correct stuff.
          targetId: '#multipart_nav', // The thing to show.
          leftOffset: function(){ return $('#sub_hed').position().left; },
          topOffset: function(){ return $('#sub_hed').position().top + $('#sub_hed').outerHeight(true); },
          onShow: function(){
            $('#multipart_nav').css('position', 'absolute');
            $('#multipart_nav').css('height', 'auto');
            $('#multipart_nav').css('overflow', 'auto');
            // subHed.find('.toggle').addClass('open-toggle');
          },
          onHide: function(){
            // subHed.find('.toggle').removeClass('open-toggle');
          }
        });
      }

      if($('#article_header').length > 0){
        // The roll up.
        $('#main_sidebar').SGRollup({ // The main element assigned to this plugin is used to trigger the drop of the rollup on desktop mode.
          rollupEl: multipartArticleRollup,
          topOffset: $('#slate_logo').height(),
          leftOffset: $('#article_header').offset().left,
          tablet: {el: $('#article_header'), topOffset: $('#article_header').height()}, // Indicate the visibility triggers for tablet mode.
          mobile: {el: $('#tablet_header'), topOffset: $('#tablet_header').height()},// Indicate the visibility triggers for mobile mode.
          onHide: function(){
            // On roll back up make sure to hide the nav if it's open, assuming it was opened by the rollup toggle.
            if(multipartArticleRollup.data('plugin_SGNavDropdown').isTargetVisible() && $('#multipart_nav').data('openedByRollup')){
              multipartArticleRollup.data('plugin_SGNavDropdown').close();
            }
          }
        });
      }

    // Multipart dropdown triggered by the rollup in the multipart nav.
      multipartArticleRollup.SGNavDropdown({
        targetId: '#multipart_nav', // The thing to show.
        extraSpecificHandle: '.handle',
        extraId: 'multipart', // Used to name events inside the plugin, so we can be sure to bind/unbind the correct stuff.
        leftOffset: function(){ return multipartArticleRollup.find('.main').offset().left; },
        topOffset: function(){
          return multipartArticleRollup.outerHeight(true)
        },
        onShow: function(){
          $('#multipart_nav').css('position', ''); // undo the absolute bit we might have affixed in subHed.SGNavDropdown().
          $('#multipart_nav').addClass('fixed').data('openedByRollup', true);
          $('#multipart_nav').css('max-height', (mobileMode() ? $(window).outerHeight(true) + 10 : $(window).height() - $('#article_rollup').height()));
          $('#multipart_nav').css('overflow', 'scroll');
          if(mobileMode()){
            $('#multipart_nav').css('right', 0);
          }
        },
        onHide: function(){
          $('#multipart_nav').data('openedByRollup', false);
        }
      });




      // Trigger the slideshow lightbox for from the .slideshow-preview example.
        $('#slideshow_preview_link').SGLightbox({
          type: 'slideshow',
          slideshowElement: $('#the_slideshow')
        });

      watchMobileRollupSocialToggle();

      $('.expandable').find('.toggle').click(function(e){
        $(this).closest('.social').toggleClass('visible');
        $('#main_byline').toggle();
        e.preventDefault();
      });

      $('.full-width').setFullWidth();

    });
});
    </script>


    
    <!-- Parsely -->
    






<div id="parsely-root" style="display: none">
  <div id="parsely-cfg" data-parsely-site="slate.com"></div>
</div>

<script>
  var parselyLoaded = false,
      parselyActionname = 'noniscrollstory';

  


  

  // Call Parsely Onload Handler
  PARSELY = {
    autotrack: false,
    onload: function() {
      parselyLoaded = true;
      PARSELY.beacon.trackPageView(parselyEvent);
    }
  };

  // Load Parsely API Script
  (function(s, p, d) {
    var h=d.location.protocol, i=p+"-"+s,
        e=d.getElementById(i), r=d.getElementById(p+"-root"),
        u=h==="https:"?"d1z2jf7jlzjs58.cloudfront.net"
        :"static."+p+".com";
    if (e) return;
    e = d.createElement(s); e.id = i; e.async = true;
    e.src = h+"//"+u+"/p.js"; r.appendChild(e);
  })("script", "parsely", document);
</script>
<!-- END Parse.ly Include -->

    



<div class="nav-header" id="magic_nav_header">
  <a class="slate-logo" href="/"><span class="logo">Slate</span></a>
  <div class="buttons"></div>
</div><!-- /.nav-header -->
<!-- HCS: layouts/shared/nav/nav -->
<div id="nav_sections"></div>
<!-- HCS END: layouts/shared/nav/nav -->

      
      







  
  
  


<section class="nav-panel" id='nav_header_for_rollup_magic'>
  <div class="nav-header">
    <a class="slate-logo" href="/"><span class="logo">Slate</span></a>
    <a href="#" class="user-link sidebar-handle"></a>
    <a href="#" class="search-link sidebar-handle"></a>
    <a href="#" class="global-nav-handle sidebar-handle"></a>
    <div class="buttons">
      
      <span class="link option"><a class="first nav-option sign-in-link" href="#">Sign In</a></span>
      <span class="link option"><a href="#" class="nav-option sign-up-link">Sign Up</a></span>
      
    </div>
  </div>
  
</section>


    <div id="nav_animation_mask">

    </div>

    
    <span class='highlighter-container'>
      <div class="social social-with-popup sharing-buttons">
        <a href="#" data-share="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=http://www.slate.com/blogs/browbeat/2017/07/18/seth_meyers_has_more_trump_scandals_than_he_knows_what_to_do_with.htmlhttp://www.slate.com/content/dam/slate/blogs/browbeat/2017/07/18/seth_meyers_has_more_trump_scandals_than_he_knows_what_to_do_with/170717_browbeat_meyers.jpg.CROP.cq5dam_web_1280_1280_jpeg.jpg&p[title]=Seth+Meyers+Has+More+Embarrassing+Trump+Stories+Than+He+Knows+What+to+Do+With&p[summary]=You+know+that+scene+at+the+end+of+the+movie+about+the+aging+racehorse+and+the+juvenile+delinquent%2C+where+it+seems+like+they%E2%80%99ve+lost+the+big+race%2C+but+t+..." class="facebook share highlighter">
          <span class="icon"></span>
        </a>
        <a href="#" data-share="http://twitter.com/share?url=http://www.slate.com/blogs/browbeat/2017/07/18/seth_meyers_has_more_trump_scandals_than_he_knows_what_to_do_with.html&count=none&via=slate" class="twitter">
          <span class="icon"></span>
        </a>
        
          <a href="#comments" class="comments" style="display: none;">
            <span class="icon"></span>
          </a>
        
      </div>
        <div class="arrow-border"></div>
        <div class="arrow"></div>
    </span>
    
<!-- HCS END: layouts/shared/bottom -->

    

  <!--
  Page Loading starts on 2017/07/18 01:25:33, Total time elapsed to render is 0.123914495 seconds, Server: pub2.slate.com
  -->
  </body>
</html>












